Pro Version Doesn't Translate My New Blog Posts

Popular automatic website translation tool

Pro Version Doesn't Translate My New Blog Posts

Postby mox22 » Sat Jul 09, 2011 5:18 pm

I purchased the pro version and had someone install it for me and get it set up. It worked fine a few days, but now it doesn't translate my new posts. What should I do?

My url is http://getpaidwithfitness.net

Thanks in advance!
mox22
 
Posts: 5
Joined: Fri Jul 08, 2011 6:47 pm

Re: Pro Version Doesn't Translate My New Blog Posts

Postby Edvard » Sat Jul 09, 2011 10:19 pm

It seems that you are exceeding your Translation API daily usage. You just need to wait. I would suggest you to turn off the languages you are not interested in to save translation traffic.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro Version Doesn't Translate My New Blog Posts

Postby mox22 » Sat Jul 16, 2011 11:17 pm

What is the easiest way to edit which the language settings?
mox22
 
Posts: 5
Joined: Fri Jul 08, 2011 6:47 pm

Re: Pro Version Doesn't Translate My New Blog Posts

Postby Edvard » Sat Jul 16, 2011 11:21 pm

Ex. to edit your home page on Spanish you need to go to http://getpaidwithfitness.net/es/?language_edit=1

In general you need to add ?language_edit=1 to your URL.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro Version Doesn't Translate My New Blog Posts

Postby mox22 » Sat Jul 16, 2011 11:47 pm

I mean how do I turn off languages I'm not interested in? It seems like it just stopped working because every post I've made in the past few weeks will not translate.

Do i need to edit the sitemap and remove some of the languages?
mox22
 
Posts: 5
Joined: Fri Jul 08, 2011 6:47 pm

Re: Pro Version Doesn't Translate My New Blog Posts

Postby Edvard » Sun Jul 17, 2011 11:27 pm

You need to remove them from sitemap.txt and also replace [a-z]{2} in .htaccess with the language names you want to be translated, e.g. en|fr|it|de|pt etc...
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro Version Doesn't Translate My New Blog Posts

Postby mox22 » Wed Jul 20, 2011 7:00 pm

I've looked all over and can't find the .htacess file, what folder is it in?

Also, do I need to edit the widget code through the wordpress dashboard and delete the languages I don't want to use?

Thanks so much for your help
mox22
 
Posts: 5
Joined: Fri Jul 08, 2011 6:47 pm

Re: Pro Version Doesn't Translate My New Blog Posts

Postby Edvard » Wed Jul 20, 2011 9:43 pm

It is in your www root folder, if you use an FTP client there should be option to display hidden files.

Yes, you'll need to remove the languages from the GTranslate language selector too.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Pro Version Doesn't Translate My New Blog Posts

Postby mox22 » Thu Jul 21, 2011 4:14 am

Ok, this is how I edit the .htacess file, Did I do it right?

#--- DH-PHP handlers ---
AddHandler fastcgi-script fcg fcgi fpl
AddHandler php-fastcgi .php
Action php-fastcgi /cgi-bin/dispatch.fcgi

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
# gtranslate config
RewriteRule ^(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)/(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)/(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteRule ^(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^(en|es|fr|ru|it|de|hi|ja|pt|th|ar|id|ms|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress


I wasn't sure if I put the languages codes in the right spots??

Also, do I need en in there if english is the default language?

Thanks again for your time
mox22
 
Posts: 5
Joined: Fri Jul 08, 2011 6:47 pm

Re: Pro Version Doesn't Translate My New Blog Posts

Postby Edvard » Thu Jul 21, 2011 3:09 pm

It is correct. Yes, you can have en too.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux