Pro version not working

Popular automatic website translation tool

Pro version not working

Postby mrnicksmith » Sat Sep 01, 2012 10:03 pm

The pro version is not working on my site.

The free version works.

I have installed according to directions but I get 404 page not found when using the pro version

also I get this
You don't have appropriate license for clinicalgenius.com domain name. Please purchase GTranslate Pro license.
When using this url
http://clinicalgenius.com/gtranslate/tr ... fy_license
mrnicksmith
 
Posts: 5
Joined: Sat Sep 01, 2012 9:44 pm

Re: Pro version not working

Postby Yana » Sun Sep 02, 2012 1:19 am

Hi,
We will check the license.If you have a problem with the installation you can send FTP access information and backend admin username/password and we will install it for you.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Pro version not working

Postby Yana » Sun Sep 02, 2012 4:03 pm

HI,
Your license is active. Could you please enable GTranslate debug mode ?
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm

Re: Pro version not working

Postby mrnicksmith » Mon Sep 03, 2012 11:20 pm

I have enabled debug mode here is the text:

* About to connect() to license.gtranslate.net port 80 (#0)
* Trying 85.17.168.121... * connected
* Connected to license.gtranslate.net (85.17.168.121) port 80 (#0)
> POST / HTTP/1.1
Host: license.gtranslate.net
Accept: */*
Content-Length: 358
Expect: 100-continue
Content-Type: multipart/form-data; boundary=----------------------------c2545e89a3c1

< HTTP/1.1 100 Continue
< HTTP/1.1 200 OK
< Date: Mon, 03 Sep 2012 19:19:06 GMT
< Server: Apache/2.0.63 (FreeBSD) PHP/5.2.17 with Suhosin-Patch mod_fcgid/2.3.6 mod_ssl/2.0.63 OpenSSL/0.9.7e-p1
< X-Powered-By: PHP/5.2.17
< Content-Length: 418
< Content-Type: text/html
<
* Connection #0 to host license.gtranslate.net left intact
* Closing connection #0
mrnicksmith
 
Posts: 5
Joined: Sat Sep 01, 2012 9:44 pm

Re: Pro version not working

Postby mrnicksmith » Mon Sep 03, 2012 11:43 pm

The license problem is resolved by setting the appropriate attributes on license.dat. However the translation is not working. It redirects to the appropriate subdirectory but it is still in english
mrnicksmith
 
Posts: 5
Joined: Sat Sep 01, 2012 9:44 pm

Re: Pro version not working

Postby mrnicksmith » Tue Sep 04, 2012 12:46 am

I was able to solve all of my problems by adding force_translate=1
Here is my rewrite rules for IIS7.5 for anyone who needs it:

<rewrite>
<rules>
<rule name="Imported Rule 1" stopProcessing="true">
<match url="^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$" ignoreCase="false" />
<action type="Redirect" url="/{R:1}/{R:3}" redirectType="Permanent" />
</rule>
<rule name="Imported Rule 2" stopProcessing="true">
<match url="^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$" ignoreCase="false" />
<action type="Redirect" url="/{R:1}/" redirectType="Permanent" />
</rule>
<rule name="Imported Rule 3" stopProcessing="true">
<match url="^([a-z]{2}|zh-CN|zh-TW)/(.*)$" ignoreCase="false" />
<conditions logicalGrouping="MatchAll">
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
</conditions>
<action type="Rewrite" url="/gtranslate/translate.php?lang={R:1}&amp;force_translation=1&amp;url={R:2}" appendQueryString="true" />
</rule>
<rule name="Imported Rule 4" stopProcessing="true">
<match url="^([a-z]{2}|zh-CN|zh-TW)$" ignoreCase="false" />
<action type="Rewrite" url="/gtranslate/translate.php?lang={R:1}&amp;force_translation=1" appendQueryString="true" />
</rule>
<rule name="wordpress" patternSyntax="Wildcard">
<match url="*" />
<conditions>
<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
</conditions>
<action type="Rewrite" url="index.php" appendQueryString="true" />
</rule>
</rules>
mrnicksmith
 
Posts: 5
Joined: Sat Sep 01, 2012 9:44 pm

Re: Pro version not working

Postby mrnicksmith » Tue Sep 04, 2012 12:59 am

Also one last thing was needed. I had to adjust my google api quotas and increase my per user limit.
mrnicksmith
 
Posts: 5
Joined: Sat Sep 01, 2012 9:44 pm

Re: Pro version not working

Postby Yana » Tue Sep 04, 2012 7:00 pm

Hi,
I can see it works. Do you still have a problem?
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4133
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux