Problems with translations on sub-pages

Popular automatic website translation tool

Problems with translations on sub-pages

Postby LAMF » Wed Feb 16, 2011 12:25 pm

I use the free version of Gtranslate and it works great on the main page and some other articles as well but when clicking on some links on sub-pages the translation stops.
Not on everyone but most of them.
I first thought I knew the reason for this but I was wrong.
I thought it had something to do with that the articles that shall be translated has to be linked to from a published menu but that seem to be a wrong theory.

Please how can I get it translating all articles in my site?
Here's the URL for my site if you want to check it out: http://www.sit-right.se

I am well willing to purchase the pro version if that one solves this issue.
LAMF
 
Posts: 37
Joined: Wed Feb 16, 2011 12:16 pm

Re: Problems with translations on sub-pages

Postby Edvard » Thu Feb 17, 2011 1:11 am

Hi,

Try to use Redirect translation method. If that solves the issue then
you are ready to go Pro.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Problems with translations on sub-pages

Postby LAMF » Thu Feb 17, 2011 1:50 am

Hi,
That almost did the trick.
Translations work on all pages but it seem to be a conflict with the Nivo Slider on the start page when I turn on another language than default (Swedish).
It's no big deal but of course it would be better if I could have the slider also on the translated start page.

Oh I also found out that the spam protection on the contact pages also didn't work in translation mode so there's got to be some kind of conflict.

Solution is close... any ideas?
Will Pro solve it?

Regards
Micke
LAMF
 
Posts: 37
Joined: Wed Feb 16, 2011 12:16 pm

Re: Problems with translations on sub-pages

Postby LAMF » Thu Feb 17, 2011 10:53 am

I know the reason why the captcha wont work in translate mode...
It's because a new url is generated when the translation is activated, so maybe I can solve it by help from the KeyCAPTCHA team, they use to be very helpful.

Thanks again Edvard for the help!
LAMF
 
Posts: 37
Joined: Wed Feb 16, 2011 12:16 pm

Re: Problems with translations on sub-pages

Postby LAMF » Thu Feb 17, 2011 12:54 pm

Just wanted to let everyone know that the KeyCAPTCHA team has solved this so now it works with KeyCAPTCHA spam protection in redirect mode.
Aint that great news!!
LAMF
 
Posts: 37
Joined: Wed Feb 16, 2011 12:16 pm

Re: Problems with translations on sub-pages

Postby Edvard » Sat Feb 19, 2011 2:47 pm

Good to hear that!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux