[Solved] %20 signs in the URL

Popular automatic website translation tool

[Solved] %20 signs in the URL

Postby chilipepper » Thu Oct 24, 2013 8:44 am

When we switch to any language we see %20 signs in the URL and then when we click on another language we get a 404 page... we get that with each language
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Yana » Thu Oct 24, 2013 10:46 am

Hi,
What is your domain name? % means that the text is in the translation queue and you will see the translated version soon. You just need to wait and everything will be translated.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: %20 signs in the URL

Postby chilipepper » Thu Oct 24, 2013 10:53 am

domain is http://goo.gl/tKjN0I (enterprise account)
how long will this take?
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Yana » Thu Oct 24, 2013 11:05 am

As the translations are done on demand it will start translating from the most popular content.
You just need to wait and your site will be translated and cached. It depending on your traffic.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: %20 signs in the URL

Postby chilipepper » Thu Oct 24, 2013 11:19 am

OK, but the Spanisch pages has more then 100 visits since yesterday already...

and on the pages where I have no 20% sign I get the same thing, each time when I change a language I go to a 404 page
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Edvard » Fri Oct 25, 2013 6:10 pm

Hi,

Currently your site is offline. Can you let us know how we can see your issue?

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 6:39 pm

site is back online but I think I just fix the problem... we did remove the gtranslate mod and also all other related things like the "<meta name="uri-translation" content="on"/>" in the <head> section, without that line it is working but now the URL is not translated
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 6:41 pm

I did put the <meta name="uri-translation" content="on"/> back
and now 20% is back in the URL
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Edvard » Fri Oct 25, 2013 6:48 pm

Hi,

Since you are using the URL translation feature your URLs are translated and in the translation there are spaces. %20 is a space which is encoded in the URLs to comply with the standards. You can manually edit the URLs and may be replace %20 with "-". Hope that makes sense.

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 6:54 pm

OK but we have more then 900 URLs to replace then... is there no other option?
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Edvard » Fri Oct 25, 2013 6:58 pm

If you confirm that you want to replace space (%20) with "-" in all of your URLs, we can do that on our side.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 6:59 pm

OK please do that
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 7:01 pm

BTW this is out test domain so when we put all of this on our main actual site I guess we only have to renew our license right and all will work again?
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Edvard » Fri Oct 25, 2013 7:05 pm

We have made the change for you.

Please let us know when you want to change and we will figure it out.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 7:08 pm

Ok the %20 sign is gone but when we now click on for example Dutch then we get the 404 page again, this goes for each language
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: %20 signs in the URL

Postby Edvard » Fri Oct 25, 2013 7:18 pm

Hi,

We will sort that issue as well using the access you gave us, it is a matter of the module misconfiguration.

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: %20 signs in the URL

Postby chilipepper » Fri Oct 25, 2013 7:29 pm

ok Thanks
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: [Solved] %20 signs in the URL

Postby chilipepper » Sun Oct 27, 2013 4:23 pm

Hi Edvard... the %20 is back again, I switch to a new theme and now it is back... did you also make some changes to the theme files?
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Re: [Solved] %20 signs in the URL

Postby Edvard » Mon Oct 28, 2013 1:38 pm

Hi,

We have not changed anything on your side about this. This will happen in future when you will add/modify URLs on your site. After that they will be translated automatically and may contain spaces after translation which will need to be corrected by you. However you shouldn't be worried about the spaces (%20). Most browsers show them as spaces and %20 is not visible at all.

We have just made another bulk replace for you.

Thank you!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: [Solved] %20 signs in the URL

Postby chilipepper » Mon Oct 28, 2013 2:26 pm

Ok, so I have to edit the URL for each language? I did edit the URL for ES but for German and all other languages it still has the %20 in the URL (Chili-Basis%20soziale) and that is in Firefox, Google chrome and IE

Also when I'm on (Chili-Basis%20soziale) or this URL (chili-base-social) (with no 20%) and I click on Dutch language it brings me to a 404 page again

And in IE I don't see the flags...

so still some errors Edvard :(
chilipepper
 
Posts: 23
Joined: Wed Oct 23, 2013 3:15 pm

Next

  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron