Switching URL's But No Translations And No Writing to Cache

Popular automatic website translation tool

Switching URL's But No Translations And No Writing to Cache

Postby james.paul » Mon Apr 30, 2012 11:26 pm

Hi, I am experiencing a problem with translations on my http://www.jamespaulphotography.co.uk website, basically I click on the flag and the url changes, the page refreshes but there is no translated text. Everything worked fine until I deleted my cache last Wednesday (completely emptied it as I redesigned deleted lots of pages - I did not want old versions to be served up). The cache folder and ar, el... folders are all 777 permissions as they should be. Since Wednesday there has been no files written into the cache folder. I tried reuploading the cache folder on Saturday also. There is also a limit.txt file with the numbers 1335811770 within it.

I have checked the debug.txt file (which I turned on Saturday) and saw that it was telling me about daily usage limit as below. I have looked through the forums and saw the advice to remove the API key. I tried this and I am still seeing no translation taking place without the API key. Therefore I am not sure that there is an API issue stopping the translations.

If it helps my config.php set up is below I have commented out the Google API so it is not in effect. You may visit the gtranslate folder at http://www.jamespaulphotography.co.uk/gtranslate/

Code: Select all
// define('API_KEY', 'AIzaSyBbVMLJZLEKi4SA7va43gk0IkOH59hCPBs'); // You need to get your Google Translate API key from https://code.google.com/apis/console/?api=translate
define('MAIN_LANG', 'en'); // en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', false); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature
define('USE_BING_TRANSLATOR', false); // Enable it to use Bing Translotor instead of Google Translate
define('BING_API_KEY', 'INSERT-YOUR-KEY'); // If the option above is enabled you need to get your Bing API key from http://www.bing.com/developers/createapp.aspx (PHP SOAP client is required)
define('DEBUG', true); // turn on for debug mode


If anyone has any suggestions please let me know. I am not sure where to start with this.
james.paul
 
Posts: 9
Joined: Mon Apr 30, 2012 10:20 pm

Re: Switching URL's But No Translations And No Writing to Ca

Postby Yana » Mon Apr 30, 2012 11:35 pm

Hi,
I can see the following lines in the dedug.txt . Please correct your API key or remove it.

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "keyInvalid",
"message": "Bad Request"
}
],
"code": 400,
"message": "Bad Request"
}
}
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Switching URL's But No Translations And No Writing to Ca

Postby james.paul » Tue May 01, 2012 1:23 am

Hi, the API has been removed but still no translations occurring on the website. I have an entry in the debug.txt from just a few minutes ago

< HTTP/1.1 400 Bad Request
< Content-Type: application/json; charset=UTF-8
< Date: Mon, 30 Apr 2012 21:17:18 GMT
< Expires: Mon, 30 Apr 2012 21:17:18 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=INSERT-YOUR-KEY&q=%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E&userip=66.249.67.65&source=MAIN_LANG&target=hi

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "keyInvalid",
"message": "Bad Request"
}
],
"code": 400,
"message": "Bad Request"
}
}

I do not have an API key in my config.php file anymore? Am I not removing it correctly? This is my config.php file now

define('API_KEY', 'INSERT-YOUR-KEY'); // You need to get your Google Translate API key from https://code.google.com/apis/console/?a ... MAIN_LANG', 'en'); // en, ar, bg, hr, cn, ct, cs, da, et, tl, fi, fr, gl, el, iw, hi, es, nl, id, ja, ca, ko, lt, lv, mt, de, no, pt, ru, ro, sr, sk, sl, sv, th, tr, uk, hu, vi, it, pl, sq
define('AUTO_DETECT_LANG', false); // set to true if you have mixed language content
define('CACHE_TIME', 365*24*60*60); // 1 year by default, no need to decrease
define('LICENSE', 'license.dat');
define('SSL_VERIFY_PEER', true); // disable if you get CA certificate error and cannot reconfigure your server to solve the issue
define('FOLLOW_LOCATION', false); // if your site have redirects for some URLs and for that reason you see blank pages, you need to enable this feature
define('USE_BING_TRANSLATOR', false); // Enable it to use Bing Translotor instead of Google Translate
define('BING_API_KEY', 'INSERT-YOUR-KEY'); // If the option above is enabled you need to get your Bing API key from http://www.bing.com/developers/createapp.aspx (PHP SOAP client is required)
define('DEBUG', true); // turn on for debug mode
james.paul
 
Posts: 9
Joined: Mon Apr 30, 2012 10:20 pm

Re: Switching URL's But No Translations And No Writing to Ca

Postby Yana » Tue May 01, 2012 2:15 am

Hi,
Please make sure that you don't have both the GTranslate Pro Joomla plugin version and the General version installed on your server. If the problem persist you can send FTP access and backend admin username /password and I'll check the settings.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm

Re: Switching URL's But No Translations And No Writing to Ca

Postby james.paul » Tue May 01, 2012 11:02 am

No I only have the version that Edvard emailed me for GTranslate Pro (3.14592) installed and the HTML version from the website in my html/php pages. I have checked every file based on the installation requirements and remember it was working until Wednesday last week with no problems. I will PM with FTP details as I am still getting bad requests,usage limits, key invalid in my debug.txt with the API removed. I had the following this morning.

< HTTP/1.1 400 Bad Request
< Content-Type: application/json; charset=UTF-8
< Date: Tue, 01 May 2012 06:56:48 GMT
< Expires: Tue, 01 May 2012 06:56:48 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=API_KEY&q=%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E&userip=66.249.67.65&source=MAIN_LANG&target=th

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "keyInvalid",
"message": "Bad Request"
}
],
"code": 400,
"message": "Bad Request"
}
}
james.paul
 
Posts: 9
Joined: Mon Apr 30, 2012 10:20 pm

Re: Switching URL's But No Translations And No Writing to Ca

Postby Yana » Thu May 03, 2012 12:42 am

Hi,
I've updated the plugin. Please check.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4129
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron