Warning: file_put_contents(cache/js

Popular automatic website translation tool

Warning: file_put_contents(cache/js

Postby sdmonad » Wed Feb 06, 2013 1:16 pm

Hi

I have a problem with cache error with a Drupal 7 site.

I got this error what is the problem?

Warning: file_put_contents(cache/js/ca7480c8382905e83c00fb8f086d74): failed to open stream: No such file or directory in /var/sites/httpd/htdocs/gtranslate/translate.php on line 305 Warning: file_put_contents(cache/js

Rgds
sdmonad
 
Posts: 8
Joined: Wed Feb 06, 2013 1:12 pm

Re: Warning: file_put_contents(cache/js

Postby sdmonad » Wed Feb 06, 2013 1:23 pm

Another issue is when you install the Drupal GT translate module it take over the upper part of your menu area so you cant access the admin drop down menus.

This site have an extra dhtml menu block installed for top drop down menus, maybe thats the reason? But how can you solve this ?

rgds
sdmonad
 
Posts: 8
Joined: Wed Feb 06, 2013 1:12 pm

Re: Warning: file_put_contents(cache/js

Postby Edvard » Wed Feb 06, 2013 2:22 pm

Hi,

Please use the following rewrite rules instead in your .htaccess:

RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !^/js
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteCond %{REQUEST_URI} !^/js
RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

Not sure about the top menu. Can you send a link, so I can check?
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Warning: file_put_contents(cache/js

Postby sdmonad » Wed Feb 06, 2013 9:41 pm

Hi

I saw and post here about the cache issue so I did this to solve the cache problem and its seems to work.

# gtranslate config
RewriteRule ^([a-z]{af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L]
RewriteRule ^([a-z]{af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z]{af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA]
RewriteRule ^([a-z]{af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW)/(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|zh-TW|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|th|tr|uk|ur|vi|cy|yi|zh-CN|zh-TW}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA]

And start all over again with installation. Its a Drupal 7. 14 site and I have to install the free GT modul by ftp.

Now the cache issues disappear but in back end there is only two settings that can be done by GT in back end. Sending you url and pic on how it looks
sdmonad
 
Posts: 8
Joined: Wed Feb 06, 2013 1:12 pm

Re: Warning: file_put_contents(cache/js

Postby Edvard » Wed Feb 06, 2013 10:02 pm

Please download and install the latest version from our website. Please provide more information how I can check the issue you have. I cannot find any image or URL.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Warning: file_put_contents(cache/js

Postby Edvard » Wed Feb 06, 2013 10:04 pm

I got the email after I posted this. I cannot see that you have installed the GTranslate module. The screenshot you sent has nothing to do with GTranslate.

If you are having problems installing it you can send us your backend access and FTP access using our contact us form on our home page and our agent will install it for you.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4185
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

2GLux