Forum Archive - 404 Not Found

404 Not Found
Jun 23, 2015 7:03 am by bonobo34
Hi, I did read throught all topics regarding 404 not fount error, but it did not solve my trouble. .htaccess file seems to be correct I've placed all requested file in the right place. Could you check and help? Sincerly Yours
Re: 404 Not Found
Jun 23, 2015 12:56 pm by Yana
Hi, Please make sure that you put gtranslate rules after "RewriteEngine On" . Also please change the license file permission to 666 If you open the translated page directly you will see the error message ... hp?lang=fr
Re: 404 Not Found
Jun 23, 2015 1:39 pm by bonobo34
Thank you for your quick reply. I did change the file permission, but I'm locked with the other issue. In the general/gtranslate/cache/.htaccess file that was in my package there were only those lines in it : # deny all direct requests Order Deny,Allow Deny from all <FilesMatch "^order_.*$"> Allow from all </FilesMatch> Is that what the file is supposed to look like? Best regards
Re: 404 Not Found
Jun 23, 2015 1:55 pm by Yana
Hi, You should add the rules in the .htaccess file which is on the root directory not in the gtranslate folder.
Re: 404 Not Found
Jul 1, 2015 11:11 am by vicki27
Hi, I have the same problem. The installation worked, but when I click on the flags I get the same error (404 Not Found) This is a screenshot of the backend of my joomla site. I have to note that I'm brandnew with Joomla (Sorry for my English, I speak Dutch), and don't understand terms like .htaccess or rules,... Can you give me a easy explanation? Thanks in advance!!
Re: 404 Not Found
Jul 1, 2015 1:58 pm by bonobo34
Hi Yana, I'm still struggling... but the translation does not translate, no more 404 since I've placed a .htaccess at the root of my WS. Vicki, the htaccess.txt file is at the root of any joomla website. You should find out and follow : 3. Add this lines AFTER (next to) RewriteEngine On line in the .htaccess file. Make sure the file name is .htaccess not htaccess or htaccess.txt. If you don't have .htaccess create one manually or rename htaccess.txt to .htaccess. # gtranslate config RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)/(.*)$ /$1/$3 [R=301,L] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/([a-z]{2}|zh-CN|zh-TW)$ /$1/ [R=301,L] RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([a-z]{2}|zh-CN|zh-TW)/(.*)$ /gtranslate/translate.php?lang=$1&url=$2 [L,QSA] RewriteRule ^([a-z]{2}|zh-CN|zh-TW)$ /gtranslate/translate.php?lang=$1 [L,QSA] Sincerly Yours,
Re: 404 Not Found
Jul 1, 2015 2:27 pm by vicki27
Bonobo, I've done these steps, and it still doesn't work... I renamed the file htaccess.txt to .htaccess. after uploading at the server (because I couldn't put a . before the name in the left side of my FTP (local site). Is this the problem?
Re: 404 Not Found
Jul 1, 2015 2:50 pm by Yana
Hi, Please try to enable gtranslate debug mode and check the debug.txt file or you can send access info by PM or email ( [email protected])and I'll check the settings.


translated page not foundnPage not foundJan 22, 2018 6:17 pmReplies: 8Post by: smileexcursions
500 error - file not foundMar 19, 2018 5:15 pmReplies: 1Post by: bigblue
(HELP) server DNS address could not be foundFeb 17, 2017 10:30 amReplies: 14Post by: kherogen
Page not found error for translated pagesMar 17, 2016 11:04 amReplies: 23Post by: sadashiv
302 Found shown on ssl pagesJul 14, 2015 10:22 amReplies: 18Post by: sadashiv

Try GTranslate with a free 15 day trial