Images not served on https page

Popular automatic website translation tool

Images not served on https page

Postby sadashiv » Fri Nov 11, 2016 11:38 am

I have the users profile served on https. We display few images of the users on this page. When I check with the default site i.e. no translation then the images get served but if I switch the language before login and then view my profile page then the images are broken. Here is a screenshot of what I see http://casetracker.gokhalemethod.com/sites/default/files/161110_logingerman.jpg

Would like to know how can I fix this.

Thanks,
Sadashiv
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Yana » Fri Nov 11, 2016 12:28 pm

Hi,
Can you send me test username password so I can check it?
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4333
Joined: Thu Jan 12, 2012 6:21 pm

Re: Images not served on https page

Postby sadashiv » Fri Nov 11, 2016 5:48 pm

Hi,

Creds send on PM.

Steps to replicate.
Open http://gokhalemethod.com" rel="nofollow" target="_blank
change language to german
click on login
enter creds
see that you see broken images after login (it takes you to your profile page)

Now you can logout
change the language to English and try the same steps and it works.

One of my co-worker also reported one more issue i.e. if you logout and change language and try to login with correct creds then it redirects you to the same login page, this cannot be replicated everytime.

Seems to me that something is wrong with ssl and translated pages or something else.

Thanks,
Sadashiv
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Yana » Sun Nov 13, 2016 8:59 pm

Hi,
Please change image URLs to relative.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4333
Joined: Thu Jan 12, 2012 6:21 pm

Re: Images not served on https page

Postby sadashiv » Mon Nov 14, 2016 9:17 pm

I changed the urls to relative and can see them changed without translation but on the translated pages its still picking the absolute urls. Is is something cached and will pick fresh eventually or something is not right?

Thanks,
Sadashiv.
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Yana » Wed Nov 16, 2016 11:44 am

Hi,
Please set cookie domain to ".gokhalemethod.com" with dot prefix.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4333
Joined: Thu Jan 12, 2012 6:21 pm

Re: Images not served on https page

Postby sadashiv » Thu Nov 17, 2016 12:54 pm

I already had that in my settings.php (drupal) and now also added to php.ini and reloaded httpd but still can't see the change. Can you update how I can check the cookie_domain is .gokhalemethod.com ?

Thanks,
Sadashiv.
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Edvard » Sun Nov 20, 2016 1:37 pm

Hi,

You can find it out by checking your browser cookies for your domain.

Right now the problem is that when you login on some language, the session cookie is not shared between your main domain and other language subdomains and you are not logged in in all languages, so when you want to load image from your main domain you are not logged in there too and it fails. If you have cookie domain with dot prefix, session cookie will be shared, so when you login on some language you will be also logged in in other languages.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4348
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Images not served on https page

Postby sadashiv » Mon Nov 21, 2016 4:50 pm

I think the problem is that in case of translated page it's taking wrong cookie domain.
I tried to login without translate and you can see that the cookie domain is .gokhalemethod.com (refer attached screen shot gokhalemethod_domain.png)
http://gokhalemethod.com/sites/default/files/theme_images/gokhalemethod_domain.png

I then tried to login with translate german (de.gokhalemethod.com) and can see the cookie domain is .de.gokhalemethod.com (refer attached screen shot de_gokhalemethod_domain.png)
http://gokhalemethod.com/sites/default/files/theme_images/de_gokhalemethod_domain.png

I have a static code of setting it to .gokhallemethod.com, can't understand why it is setting to .de.gokhalemethod.com


Thanks,
Sadashiv.
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Edvard » Thu Nov 24, 2016 1:03 am

Hi,

You need to make sure that the cookie domain for your session cookie is set to .gokhallemethod.com.

If you can send admin and ftp access to [email protected] I can look into. Please mention where should I look if you know.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4348
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Images not served on https page

Postby sadashiv » Thu Nov 24, 2016 8:52 am

In my screen shots the cookies with pattern SESS* are the session cookies and as you can see the translated pages are showing .de.gokhalemethod.com I don't know why this is happening as I have ".gokhalemethod.com" hardcoded as cookie domain in my php.ini as well as in drupal settings.php file.

Thanks,
Sadashiv
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby sadashiv » Mon Nov 28, 2016 7:24 pm

Hi

Would like to know how we can solve this? Also if you check the non translated page shows relative urls and the translated page shows absolute urls, I think I made them relative and if served relative then will show the images as the cookie for the current sub domain will be used as suggested at images-not-served-https-page-t5159.html#p21468

Thanks,
sadashiv
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Edvard » Wed Nov 30, 2016 11:15 pm

Hi,

We will need to solve the issue with cookie domain. If you can provide access I can look into for you.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4348
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Images not served on https page

Postby sadashiv » Thu Dec 01, 2016 7:35 am

Hi,

I'll need your ip address so that I can add it to my firewall then I'll PM the creds.

Thanks,
sadashiv
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby Edvard » Fri Dec 02, 2016 12:20 am

Hi,

I do not have a static IP. My IP changes from time to time.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4348
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Images not served on https page

Postby sadashiv » Fri Dec 02, 2016 9:45 am

We can't keep a open ssh as we face attacks and cause the network to fail. I can send snippets of files you want and you can verify. Please update which files you want and I'll attach the files or part of the files here.

Thanks,
Sadashiv.
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm

Re: Images not served on https page

Postby sadashiv » Tue Feb 07, 2017 2:19 pm

Hey,

Would like to know whether you can help me to debug this.

Thanks,
Sadashiv.
sadashiv
 
Posts: 73
Joined: Thu Oct 09, 2014 2:02 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux