Only partially translating in Pro. Used to be ok ??

Popular automatic website translation tool

Only partially translating in Pro. Used to be ok ??

Postby antonjames » Wed Sep 19, 2012 5:30 pm

Hi,

We have a website that uses Gtranslate Pro as part of Wordpress. It has been working fine translating until recently, and for some reason it either doesn't translate or partially translate.

You can view a typical page here to see for yourself:
http://www.kitchoo.com/collection/cuisine-k1-mini-kitchens-compact-minicuisines-kitchenettes-bloccuisines/

We originally set it up with an google API key and this is placed with config.php and recently set it to debug mode.

Debug.txt gives:

< HTTP/1.1 200 OK
< Date: Wed, 19 Sep 2012 13:08:28 GMT
< Server: Apache/2.2.9 (Fedora)
< X-Powered-By: PHP/5.2.6
< X-Pingback: http://www.kitchoo.com/xmlrpc.php
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
<
* Connection #0 to host http://www.kitchoo.com left intact
* Closing connection #0
* About to connect() to http://www.googleapis.com port 443 (#0)
* Trying 74.125.132.95... * connected
* Connected to http://www.googleapis.com (74.125.132.95) port 443 (#0)
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* SSL connection using SSL_RSA_WITH_RC4_128_MD5
* Server certificate:
* subject: CN=*.googleapis.com,O=Google Inc,L=Mountain View,ST=California,C=US
* start date: Aug 16 12:25:38 2012 GMT
* expire date: Jun 07 19:43:27 2013 GMT
* common name: *.googleapis.com
* issuer: CN=Google Internet Authority,O=Google Inc,C=US
> POST /language/translate/v2 HTTP/1.1
Host: http://www.googleapis.com
Accept: */*
X-HTTP-Method-Override: GET
Content-Length: 210
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 403 Forbidden
< Content-Type: application/json; charset=UTF-8
< Date: Wed, 19 Sep 2012 13:08:29 GMT
< Expires: Wed, 19 Sep 2012 13:08:29 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host http://www.googleapis.com left intact
* Closing connection #0
Request: key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx&q=%0D%0A%09cuisine+K1++%7C++compact+kitchens+%7C+mini+cuisine+%7C+kitchenette+%7C+bespoke+award-winning+design+%7C+kitchoo%09&userip=81.152.97.250&source=fr&target=en

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "dailyLimitExceeded",
"message": "Daily Limit Exceeded"
}
],
"code": 403,
"message": "Daily Limit Exceeded"
}[/i]

Is it just a case that the daily limit is exceeded ? The problem with that is when i log into Google and view stats for that API, is says:
Daily quota: 0
28-day total: 0
Status: No known issues

To get this to work would you suggest we set up billing with Google (which we have never needed to do before) ?

Or i read on some posts in the support forum, we don't need to use an API in Pro as its optional. If that's the case how do we turn it off ? I tried changing the config/php line to:
define('API_KEY', '');
But that gave an error

< HTTP/1.1 400 Bad Request
< Content-Type: application/json; charset=UTF-8
< Date: Wed, 19 Sep 2012 12:55:26 GMT
< Expires: Wed, 19 Sep 2012 12:55:26 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host http://www.googleapis.com left intact
* Closing connection #0
Request: key=&q=k1_f02&userip=81.152.97.250&source=fr&target=en

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "keyInvalid",
"message": "Bad Request"
}
],
"code": 400,
"message": "Bad Request"
}
}


Did i do this correctly, or how do i turn off the API ?

We aren't bothered to use API stats, we just want the translation to work. If we don't use API is there any down benefits we lose out on except API stats ?

I also tried to force a translation with ?force_translation=1 and i just get a list saying cannot translate

Please see:
http://www.kitchoo.com/en/collection/cuisine-k1-mini-kitchens-compact-minicuisines-kitchenettes-bloccuisines/?force_translation=1

Any suggestions as to whats happening with ALL of the above and more importantly how to solve it would be greatly appreciated.

GTranslate has been a fantastic plugin up to now.

ps if you need GTranslate Team require ftp details etc, please let me know where to send them to.

Thank you, Anton
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby Yana » Fri Sep 21, 2012 2:19 am

Hi,
You have reached the daily limit. You just need to wait or you can remove the API key.
define('API_KEY', 'INSERT-YOUR-KEY');
API key is an optional feature.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Fri Sep 21, 2012 2:49 am

Yana, I deleted the line: define('API_KEY', 'INSERT-YOUR-KEY') in config.php to remove the API key and its still only partially translating. I then did a force translation (as suggested in the forum) which you can see at: http://www.kitchoo.com/en/a-propos-abou ... nslation=1 and this is still giving the same errors as i stated in my initial post above. Please see for yourself.

Whats broken with this ? Just because the API has reached its daily limit its killed the plugin ??? Then when i tell it to ignore Google API its still not working.

Whats your next suggestion to either get this to work or a workaround ??
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Mon Sep 24, 2012 1:53 pm

Sorry need to bump this...
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby Yana » Mon Sep 24, 2012 7:55 pm

Hi,

I can see the following lines :

< HTTP/1.1 400 Bad Request
< Content-Type: application/json; charset=UTF-8
< Date: Mon, 24 Sep 2012 15:22:31 GMT
< Expires: Mon, 24 Sep 2012 15:22:31 GMT
< Cache-Control: private, max-age=0
< X-Content-Type-Options: nosniff
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< Server: GSE
< Transfer-Encoding: chunked
<
* Connection #0 to host www.googleapis.com left intact
* Closing connection #0
Request: key=API_KEY&q=Mentions+l%C3%A9gales&userip=46.19.100.110&source=fr&target=en

Response: {
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "keyInvalid",
"message": "Bad Request"
}
],
"code": 400,
"message": "Bad Request"
}
}

Please check your API key.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Mon Sep 24, 2012 8:11 pm

Yana, i did what you told me to do, i REMOVED the API key. See you post above.
I deleted the line in the config.php file:
define('API_KEY', 'INSERT-YOUR-KEY');
If that is the incorrect way to turn off Google API, how do we do it ? Please instruct fully.

Thank you
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby Yana » Mon Sep 24, 2012 8:58 pm

Hi,

I think you have installed an older version . Could you please send me your email address? I'll send you the latest version.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Tue Sep 25, 2012 1:35 pm

We are using Version 1.0.27
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby Yana » Thu Sep 27, 2012 10:28 am

Hi,
The latest version is 3.141592 .
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Fri Sep 28, 2012 1:27 pm

HI Yana
I have tried to install the newer version you sent but i am getting: "The requested URL /en/ was not found on this server"

I followed the Wordpress installation txt file, but i maybe i've missed something ?? I've double checked folder permissions, the .htaccess file and robots.txt (which i had from the previous version)...and double checked what i should of done.... i've also checked the forum to see if there was any things i needed to do, but have no joy.

We need the translation working as we just had an exhibition too...

Do you mind having a look at the install ? Can i email you our ftp details and WP login.

ps teh main language of the website is french, and fortunately that is working still.

Thank you
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby antonjames » Fri Sep 28, 2012 2:48 pm

Hi Yana

I managed to figure it out. The .htaccess file was incorrect. I thought I hadn’t got one (as that ftp software kept it hidden) so I created a new one, but obviously the new one didn’t have the default wordpress bits.

I then used a different ftp client that showed the .htacess file. I then added the wordpress bits with the gtanslate part and its all ok and the gtranslate is fully functioning again.

Thank you for your assistance
antonjames
 
Posts: 7
Joined: Wed Sep 19, 2012 5:00 pm

Re: Only partially translating in Pro. Used to be ok ??

Postby Yana » Sat Sep 29, 2012 3:49 pm

Hi,
For wordpress you shoud install the General version. Here is the documentation: https://gtranslate.io/docs/57-gtranslat ... on#general

If you want I can install it for you.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4135
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron