Forum Archive - Remove languages

Remove languages
Mar 27, 2011 7:32 am by pert7
Hello there! I use pro version and I want to remove some languages permanently because I have a lot GB in my cache (gtranslate creates 3-4GB per day!!!!!!). I have already disable the languages from gtranslate module but it's necessary to remove them also from robots.txt to stop caching? When I remove some languages, the data appears again in cache directory because the pages is indexed from Google. What can I do? And one last question: I wonder what size (kb) is approximately a cache page with 300-500 words? Every cache file is only one page in only one language?
Re: Remove languages
Mar 29, 2011 2:22 pm by Edvard
It is strange that you have 3-4 GB. Which version do you use? There is 100.000 character daily limit, so daily traffic cannot be more than 100 KB. To do that you will need to replace [a-z]{2} in .htaccess with the language codes you want to stay enabled separated by |. Ex. en|ru|it|fr|pt|etc...
Re: Remove languages
Apr 1, 2011 9:04 am by pert7
I have update to the last version recently but I had the same problem before. Unfortunately, Google has index 30-40.000 translated pages and after I delete cache files, these files appears again in 2-3 days!!! The daily limit not working.. I like this component very much but I can't use it in my server because I need a lot of Giga. :cry: Maybe you have an updated pro version?? You mean like this for the change? ^(en|ru|it|fr|pt|)/(.*)$ / ^(en|ru|it|fr|pt|)$ /[/b] Also, I leave the following lines as it is? ^(zh-CN)/(.*)$ ^(zh-CN)$ ^(zh-TW)/(.*)$ ^(zh-TW)$ /
Re: Remove languages
Apr 4, 2011 12:08 pm by Edvard
Which version do you use??? You can find that out by going to a translated page and viewing the GTranslate signature in the end of the page source code.
Re: Remove languages
Apr 4, 2011 9:55 pm by pert7
The gtranslate module is 1.5.x.22 but I can't find which is the pro version. The only thing I can find at the end of the source code is something like that: <!-- generated by GTranslate on Wed, 03 Nov 2010 00:54:05 +0200 visit -->. I bought the pro version in last June and I haven't receive an update until now...
Re: Remove languages
Apr 5, 2011 7:23 pm by Edvard
Just sent the latest version.
Re: Remove languages
Apr 6, 2011 4:14 pm by pert7
Thank you very much for the update!! :) I have already install from the beginning the new version BUT when I select a language, I see translated only some menus and not the content. :( Why this happens? I have 777 only in cache folder.
Re: Remove languages
Apr 6, 2011 4:35 pm by Edvard
You have exceeded your API key daily usage limit. You need to wait. Make sure that cache/XX folders are writable. If they are you will be able to find files at least in one of the language folders.
Re: Remove languages
Apr 7, 2011 10:35 pm by pert7
I don' t know why but with only 5% usage of my API key, it translates only some titles on the top menu, at the bottom of the page and in some other modules. My content remains in the original language... My cache folder has 777 and the folders inside 755. I can see translated files in there with 50-150 bytes each of them.
Re: Remove languages
Apr 8, 2011 4:11 pm by Edvard
I can see that the limit for today is exceeded. Which language did you test? Did you clear the cache manually? How many files do you have in gtranslate/cache/en/ folder?
Re: Remove languages
Apr 8, 2011 5:27 pm by pert7
1. The limit exceed in a few minutes every day. 2. I tested a lot of languages.. German, English, italian etc. 3. No, I haven't clear the cache manually in the new version but I have made a new install from the beginning. 4. In english folder I have 80 files.
Re: Remove languages
Apr 11, 2011 4:35 pm by Edvard
I can already find the menus and some parts of your home page are translated into English. Can you try to decrease the text amount being shown on the home page for every article? Make the size half of what you have currently. Can you say that the cache size is growing every day?
Re: Remove languages
Apr 11, 2011 10:59 pm by pert7
Yes, menus and titles are translated into English but you won't find a word translated inside an article or a word from my content. Unfortunately, I think that something goes wrong with the translation of my articles, I don't know why... I have already make a new install and I have change API key but the problem still exists.. :(
Re: Remove languages
Apr 13, 2011 9:09 am by Edvard
I can already see some progress, please check Can you respond to my questions in the previous post?
Re: Remove languages
Apr 13, 2011 8:39 pm by pert7
Yes, the cache size is growing every day and I think that the translate works now! I found an article in English!! :D I think that I have a lot articles and for this reason I can't find many of them in other languages currently... Correct? Maybe it's better for websites like mine (with a lot of pages) to have fewer languages for quicker translation of the content? And is there any possibility to have problem with space in the future with this version? I can't use more that 3 GB because I'm in a shared server. PS: My partners don't want to decrease my intros of the home page. But I don't care to translate home page, I only care for the articles. PS2: After 10 days, I have already 20.000 files translated inside cache folder and 578 files in english language (2,5MB). I hope it's normal.
Re: Remove languages
Apr 14, 2011 9:43 am by Edvard
You can disable some of the not necessary languages to save translation bandwidth. The cache in the new version will be much-much-much more less than in the previous versions.


How to remove mobile Language Select Button transparencyDec 5, 2018 10:06 pmReplies: 10Post by: JeffTR
How do I add Indian languages in Drupal GTranslate?Sep 18, 2011 6:10 amReplies: 26Post by: rag_gupta
Code to use in Google Analytics to track languagesNov 16, 2015 10:46 amReplies: 9Post by: lucysadler
Different languages - different bannersMar 27, 2018 11:20 amReplies: 3Post by: samdo
Remove <h1>Original Text</h1>Sep 18, 2015 2:21 pmReplies: 6Post by: adeblath

Try GTranslate with a free 15 day trial