Site translating without reason on form

Popular automatic website translation tool

Site translating without reason on form

Postby jtcreative » Wed Feb 19, 2014 3:47 pm

I use RSForm to create registrations for an event on my site which is using GTranslate Pro:
http://www.singaporeyachtshow.com/visitor-registration

Users have complained that when trying to register for our event that the site is changing to a foreign language as they fill out the form.

I have unpublished the module and disabled the plugin. Will this prevent the issue or do I have to uninstall GTranslate?

The Gtranslate module was previously set to publish status 'special' so that our translators, with frontend with user permissions, could edit the google translations before making the module live on the public frontend.

The people complaining about the error are not registered users to the site. They are just members of the public trying to to fill out the form. They are unable to do so as the website is changing to a foreign language as they fill out the form.

Auto detect language was disabled so it makes no sense why the site would translate without reason.

We want to get this translation function fixed ASAP.
Hope you can help.
jtcreative
 
Posts: 4
Joined: Wed Feb 19, 2014 3:37 pm

Re: Site translating without reason on form

Postby Yana » Thu Feb 20, 2014 12:53 pm

Hi,

Can you please activate GTranslate, so I can investigate the issue and understand what the problem is?
If you enabled the system cache please try to turn off it for registration form. Also try to change gtranslate and cache plugins order.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4134
Joined: Thu Jan 12, 2012 6:21 pm

Re: Site translating without reason on form

Postby jtcreative » Fri Feb 21, 2014 1:59 am

Thanks for getting back to me Yana.

Unfortunately I cannot reactivate Gtranslate on singaporeyachtshow.com as it is causing issues with users registering for our event.

Luckily, I have purchased GTranslate Pro for another domain (http://thisisgraphicart.com) where I have an exact duplicate of the Singapore Yacht Show website for testing purposes. It is also on the same VPS server with the same server settings. In theory we can solve the issue there first and then do the fix on the singaporeyachtshow.com site.

Yana wrote:Hi,

If you enabled the system cache please try to turn off it for registration form. Also try to change gtranslate and cache plugins order.


Can you please explain how to do the above? How do I turn system cache off for just the GTranslate plugin and change the cache plugins order? Sorry - my Joomla knowledge is not as good as yours.

I have also been notified that it is not just the form that is having this issue. Another user reported it happening randomly when they clicked the Latest News page.

I have also noticed that after a language is selected if you click the 'Contact Us' tab at the top of the page - the site reverts back to English.

Hope you can respond quickly as we need to fix this by tomorrow. We have translators booked in to edit the google translations.

Many thanks
jtcreative
 
Posts: 4
Joined: Wed Feb 19, 2014 3:37 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux