Some languages load, and others don't

Popular automatic website translation tool

Some languages load, and others don't

Postby [email protected] » Fri Jul 08, 2011 8:18 am

I purchased gtranslate pro and followed the instructions to the "T" (using wordpress). When I use /es/, things load perfectly and fully. If I do /jp/ or /du/, nothing gets translated, and sometimes it says "cannot translate: {insert title and tag here}, and if I do /fr/, only the first post or so gets translated. It doesn't appear that I can attach a file so here's what the debug looks like:

* About to connect() to http://www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to http://www.musictoprayby.com (184.168.51.247) port 80
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Host: http://www.musictoprayby.com
Accept: */*
Cookie: __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; wp-settings-time-2=1310097791; wp-settings-2=m0%3Do%26m1%3Dc%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Do%26m6%3Do%26m7%3Do%26m8%3Do%26m9%3Do%26m10%3Do%26m11%3Do%26m12%3Do%26m13%3Do%26hidetb%3D1%26urlbutton%3Durlnone%26editor%3Dtinymce%26align%3Dcenter%26imgsize%3Dfull%26uploader%3D1; wordpress_logged_in_b4d10bca6d49badbc8802262696a46ef=ron%7C1310181985%7C91194ea8d8d20dba0f15d75d95706a8e; wordpress_test_cookie=WP+Cookie+check; PHPSESSID=3bedc120be48534ce7fc83efcf28c8ed; wp-settings-time-9=1307427766; __utmz=139322543.1310097822.59.7.utmcsr=texasworshipleaders.com|utmccn=(referral)|utmcmd=referral|utmcct=/newest-sponsor-music-to-pray-by/; __utmc=139322543; __utmb=139322543.3.10.1310097822; __utma=139322543.1308888980.1308929428.1310046357.1310097822.59; __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; __qca=P0-1000906065-1303762287881

< HTTP/1.1 200 OK
< Date: Fri, 08 Jul 2011 04:07:40 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Link: <http://wp.me/ic2E>; rel=shortlink
< Last-Modified: Fri, 08 Jul 2011 04:07:41 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Connection #0 to host http://www.musictoprayby.com left intact
* Closing connection #0
* About to connect() to http://www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to http://www.musictoprayby.com (184.168.51.247) port 80
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Host: http://www.musictoprayby.com
Accept: */*
Cookie: __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; wp-settings-time-2=1310097791; wp-settings-2=m0%3Do%26m1%3Dc%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Do%26m6%3Do%26m7%3Do%26m8%3Do%26m9%3Do%26m10%3Do%26m11%3Do%26m12%3Do%26m13%3Do%26hidetb%3D1%26urlbutton%3Durlnone%26editor%3Dtinymce%26align%3Dcenter%26imgsize%3Dfull%26uploader%3D1; wordpress_logged_in_b4d10bca6d49badbc8802262696a46ef=ron%7C1310181985%7C91194ea8d8d20dba0f15d75d95706a8e; wordpress_test_cookie=WP+Cookie+check; PHPSESSID=3bedc120be48534ce7fc83efcf28c8ed; wp-settings-time-9=1307427766; __utmz=139322543.1310097822.59.7.utmcsr=texasworshipleaders.com|utmccn=(referral)|utmcmd=referral|utmcct=/newest-sponsor-music-to-pray-by/; __utmc=139322543; __utmb=139322543.4.10.1310097822; __utma=139322543.1308888980.1308929428.1310046357.1310097822.59; __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; __qca=P0-1000906065-1303762287881

< HTTP/1.1 200 OK
< Date: Fri, 08 Jul 2011 04:07:53 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Link: <http://wp.me/ic2E>; rel=shortlink
< Last-Modified: Fri, 08 Jul 2011 04:07:53 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Connection #0 to host http://www.musictoprayby.com left intact
* Closing connection #0
* About to connect() to http://www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to http://www.musictoprayby.com (184.168.51.247) port 80
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Host: http://www.musictoprayby.com
Accept: */*
Cookie: __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; wp-settings-time-2=1310097791; wp-settings-2=m0%3Do%26m1%3Dc%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Do%26m6%3Do%26m7%3Do%26m8%3Do%26m9%3Do%26m10%3Do%26m11%3Do%26m12%3Do%26m13%3Do%26hidetb%3D1%26urlbutton%3Durlnone%26editor%3Dtinymce%26align%3Dcenter%26imgsize%3Dfull%26uploader%3D1; wordpress_logged_in_b4d10bca6d49badbc8802262696a46ef=ron%7C1310181985%7C91194ea8d8d20dba0f15d75d95706a8e; wordpress_test_cookie=WP+Cookie+check; PHPSESSID=3bedc120be48534ce7fc83efcf28c8ed; wp-settings-time-9=1307427766; __utmz=139322543.1310097822.59.7.utmcsr=texasworshipleaders.com|utmccn=(referral)|utmcmd=referral|utmcct=/newest-sponsor-music-to-pray-by/; __utmc=139322543; __utmb=139322543.5.10.1310097822; __utma=139322543.1308888980.1308929428.1310046357.1310097822.59; __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; __qca=P0-1000906065-1303762287881

< HTTP/1.1 200 OK
< Date: Fri, 08 Jul 2011 04:07:59 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Link: <http://wp.me/ic2E>; rel=shortlink
< Last-Modified: Fri, 08 Jul 2011 04:08:00 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Connection #0 to host http://www.musictoprayby.com left intact
* Closing connection #0

Please let me know if there's any other info you need.

Thanks,
Ron
[email protected]
 
Posts: 7
Joined: Fri Jul 08, 2011 8:12 am

Re: Some languages load, and others don't

Postby [email protected] » Fri Jul 08, 2011 8:29 am

Something to add - other languages take forever to load. I just tried /in/ and it took forever, but ended up spitting out a bunch of these lines:

Warning: file_put_contents(cache/in/a5ca0b5894324f8bb54bb9fffad29d1e) [function.file-put-contents]: failed to open stream: No such file or directory in /home/content/75/7953075/html/gtranslate/translate.php on line 174
[email protected]
 
Posts: 7
Joined: Fri Jul 08, 2011 8:12 am

Re: Some languages load, and others don't

Postby Edvard » Sat Jul 09, 2011 10:36 pm

Make sure that your cache folder is writable (777 permission). It can be necessary to put 777 permission to language folders inside the cache. Check if you have files for example in gtranslate/cache/es folder.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Some languages load, and others don't

Postby [email protected] » Sun Jul 17, 2011 9:48 am

Apparently, even though I did a chmod to 777 for the cache directory and all the subs, the subdirectories were still 707. I've made sure all files and directories within the cache directory have 777 permissions, and I still have the same issue. Apparently, the subtitle is getting translated, but nothing else. I enabled debugging, tried the first country in the list (af), and here is the output:


* About to connect() to www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to www.musictoprayby.com (184.168.51.247) port 80
> GET /?p=257 HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.musictoprayby.com
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Sun, 17 Jul 2011 05:45:06 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Link: <http://wp.me/pic2E-49>; rel=shortlink
< Set-Cookie: PHPSESSID=7b86104304b0d3c33db3e707e03e7ede; path=/
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Connection #0 to host www.musictoprayby.com left intact
* Closing connection #0
* About to connect() to www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to www.musictoprayby.com (184.168.51.247) port 80
> GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Host: www.musictoprayby.com
Accept: */*
Cookie: __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; wp-settings-time-2=1310861971; wp-settings-2=m0%3Do%26m1%3Dc%26m2%3Dc%26m3%3Dc%26m4%3Dc%26m5%3Do%26m6%3Do%26m7%3Do%26m8%3Do%26m9%3Do%26m10%3Dc%26m11%3Do%26m12%3Do%26m13%3Do%26hidetb%3D1%26urlbutton%3Durlnone%26editor%3Dtinymce%26align%3Dcenter%26imgsize%3Dfull%26uploader%3D1; PHPSESSID=0909d6466411029e0cd94922aead5430; wordpress_logged_in_b4d10bca6d49badbc8802262696a46ef=ron%7C1311487581%7C9c114fe4ac0a04532f529b4e89c79fd1; wp-settings-time-9=1307427766; __utmz=139322543.1310881405.82.30.utmcsr=texasworshipleaders.com|utmccn=(referral)|utmcmd=referral|utmcct=/newest-sponsor-music-to-pray-by/; __utmc=139322543; __utmb=139322543.4.10.1310881405; __utma=139322543.1308888980.1308929428.1310876163.1310881405.82; __cfduid=daeaf899d5cad370b4f9b7d748cddf0791308932060; __qca=P0-1000906065-1303762287881

< HTTP/1.1 200 OK
< Date: Sun, 17 Jul 2011 05:45:10 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Expires: Wed, 11 Jan 1984 05:00:00 GMT
< Cache-Control: no-cache, must-revalidate, max-age=0
< Pragma: no-cache
< Link: <http://wp.me/ic2E>; rel=shortlink
< Last-Modified: Sun, 17 Jul 2011 05:45:11 GMT
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
* Connection #0 to host www.musictoprayby.com left intact
* Closing connection #0
* About to connect() to www.musictoprayby.com port 80
* Trying 184.168.51.247... * connected
* Connected to www.musictoprayby.com (184.168.51.247) port 80
> GET /?m=201006 HTTP/1.1
User-Agent: Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Host: www.musictoprayby.com
Accept: */*
Cookie:

< HTTP/1.1 200 OK
< Date: Sun, 17 Jul 2011 05:45:21 GMT
< Server: Apache
< X-Pingback: http://www.musictoprayby.com/xmlrpc.php
< Set-Cookie: PHPSESSID=c39645a9bb1171d476832bd3a6f158ec; path=/
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=UTF-8
< X-Pad: avoid browser bug
* Connection #0 to host www.musictoprayby.com left intact
* Closing connection #0

Thanks,
Ron
[email protected]
 
Posts: 7
Joined: Fri Jul 08, 2011 8:12 am

Re: Some languages load, and others don't

Postby Edvard » Sun Jul 17, 2011 11:29 pm

After doing that changes, do you see files inside any of cache/XX folders? If not, contact your hosting provider and ask how to make that folders writable.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


Re: Some languages load, and others don't

Postby Edvard » Tue Jul 19, 2011 1:11 pm

You can move to Bing if you want. But probably you are just hitting your daily limit. You can check here: https://code.google.com/apis/console/
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4179
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: Some languages load, and others don't

Postby [email protected] » Tue Jul 19, 2011 5:50 pm

Yeah - based on that console, I've been hitting my character limit every day since I did chmod on the cache and sub folders. I know I did this at the beginning and applied it to all files and subdirectories in the cache, but I didn't verify. For it to take, I ended up having to change everything to something other than 777, then back to 777 for some reason. That must have been the issue this whole time. Thanks for your help.
[email protected]
 
Posts: 7
Joined: Fri Jul 08, 2011 8:12 am


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux