version PHP errors

Popular automatic website translation tool

version PHP errors

Postby Baboo » Tue Jan 19, 2016 1:00 am

Hello,

I have a problem with GT and PHP. When I upgrade from PHP 5.3 to 5.5. on my website aare errors:

Strict Standards: Non-static method modGTranslateHelper::getParams() should not be called statically in /data/web/virtuals/35888/virtual/www/modules/mod_gtranslate/mod_gtranslate.php on line 13

Strict Standards: Only variables should be assigned by reference in /data/web/virtuals/35888/virtual/www/modules/mod_gtranslate/tmpl/default.php on line 115

Strict Standards: Only variables should be assigned by reference in /data/web/virtuals/35888/virtual/www/modules/mod_gtranslate/tmpl/default.php on line 130

Strict Standards: Only variables should be assigned by reference in /data/web/virtuals/35888/virtual/www/modules/mod_gtranslate/tmpl/default.php on line 142

Thanks all.

Dalibor
Baboo
 
Posts: 1
Joined: Tue Jan 19, 2016 12:51 am

Re: version PHP errors

Postby Edvard » Tue Jan 19, 2016 4:31 am

Hi,

You will need to disable strict standards notice reporting.

From security perspective you should have error reporting off for production websites.

Thanks!
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4183
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux
cron