404 errors from links to my site after uninstall

Popular automatic website translation tool

404 errors from links to my site after uninstall

Postby Nirmalanow » Thu Jul 04, 2013 8:40 pm

Hi Edvard,

I have a quick question for you. I had Gtranslate Pro on my site several years ago, and then changed my mind and removed it. However, in my Google Webmaster Tools I still get a lot of 404 errors for links to my site using the two digit language codes from Gtranslate. Do you have any idea where these links are being generated?

I just upgraded my site to Joomla 3.0, and there is no code from Gtranslate on there. However, the old site is still live on a temporary address, so if somehow the old site is generating those links, then maybe the error messages will stop when I take down the old version of my site.

Any idea how the gtranslate links to my site are being generated and then followed by the Google robots even though the plugin is uninstalled?

Thanks.
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: 404 errors from links to my site after uninstall

Postby Nirmalanow » Thu Jul 04, 2013 8:43 pm

PS: there is nothing in my sitemap referencing gtranslate as I removed that info.
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: 404 errors from links to my site after uninstall

Postby Edvard » Thu Jul 04, 2013 8:44 pm

Hi,

Your old website translated pages has already been indexed. You may redirect URLs with language code to your main website. However you can take no action and leave it as is and over time the errors will go away.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 errors from links to my site after uninstall

Postby Nirmalanow » Thu Jul 04, 2013 9:00 pm

Yes, the old site was indexed with Gtranslate at one time, but I removed the gtranslate plugin from my old site over two years ago in March of 2011. If the links should disappear over time, it seems they would be gone by now. Any idea why I am still getting 404 error messages today?
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: 404 errors from links to my site after uninstall

Postby Edvard » Thu Jul 04, 2013 9:02 pm

In webmaster tools it should show where the link comes from. Please check there and you will get the answer.
Regards,

Edvard Ananyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Edvard
Site Admin
 
Posts: 4186
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: 404 errors from links to my site after uninstall

Postby Nirmalanow » Fri Jul 05, 2013 1:02 am

the links were either coming from my site or no data available. I did discover that there was an old file in my root folder called htaccess.txt which still had gtranslate code in it. Would that have generated the links even though there was another more recent htacess file (with no .txt suffix)?
Nirmalanow
 
Posts: 28
Joined: Sun Jan 02, 2011 8:34 am

Re: 404 errors from links to my site after uninstall

Postby Yana » Sat Jul 06, 2013 9:48 am

Hi,

htaccess.txt cannot generate the language code. It should be .htaccess. You can add the redirect rules in your .htaccess to redirect the translated pages links the homepage.
Here is an example:
RewriteEngine On
RewriteRule ^(fr|de|it)/(.*)$ /$2 [R=301,L]
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 errors from links to my site after uninstall

Postby Artur » Wed Sep 04, 2013 2:09 pm

Hey,
I try to reinstall whole addon, and after uninstalling my website is working only on homepage, other sites have 404 error. I've everything like you wrote on documentation.
Artur
 
Posts: 6
Joined: Wed Sep 04, 2013 2:00 pm

Re: 404 errors from links to my site after uninstall

Postby Yana » Wed Sep 04, 2013 2:57 pm

Hi,

Please check your .htaccess file and joomla global settings. It is possible that you have disabled " Use URL rewriting" option.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm

Re: 404 errors from links to my site after uninstall

Postby Artur » Wed Sep 04, 2013 3:24 pm

Aaaa yes. :P Maybe is a good idea to add this to uninstalling instruction (I have renamed .htaccess)?
I will try to install it again, but I have similar problem after installing gtranslate
http://mydomain.com/pl has 404 error, but http://mydomain.com/ is working just fine.
Artur
 
Posts: 6
Joined: Wed Sep 04, 2013 2:00 pm

Re: 404 errors from links to my site after uninstall

Postby Yana » Wed Sep 04, 2013 4:23 pm

Hi,
We have free installation service. If you want I can install the plugin for you . You can use the contact form on our homepage to send the access information.
Regards,

Yana Ghahramanyan - GTranslate Team

Please leave your feedback on your CMS plugin directory. It is very important for us!
Google Translate Joomla
Google Translate WordPress
Google Translate Drupal
Yana
 
Posts: 4140
Joined: Thu Jan 12, 2012 6:21 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux